Sitecore: Publishing stuck on Initializing after applying Scalability settings

SitecoreI recently came across this issue after applying some scalability settings, and couldn’t initially figure out why the publishing was no longer working.  Accessing the Desktop and using site publishing would display the dialog, but would hang on the Initializing… stage.  After some preliminary investigation, it turned out that the issue was with the instance names provided in the scalability settings.

Initial Investigation

Some investigation on the web turned up a few possible solutions, but they didn’t work for me.  In case these might be helpful for your scenario, here they are:

Scalability Settings Problem

In my particular case, this was not the root cause of the issue.  After examining my changes to the scalability settings, I noticed I had incorrectly set the local instance name on the authoring server.  Both my content delivery and authoring servers had the same instance configurations:

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
   <sitecore>
      <settings>
         <!-- INSTANCE NAME
            Unique name for Sitecore instance.
            Default value: (machine name and IIS site name)
         -->
         <setting name="InstanceName">
            <patch:attribute name="value">MySite1</patch:attribute>
         </setting>
         <!-- PUBLISHING INSTANCE
            Assigns the instance name of dedicated Sitecore installation for publishing operations.
            When empty, all publishing operations are performed on the local installation of Sitecore.
            Default vaue: (empty)
         -->
         <setting name="Publishing.PublishingInstance">
           <patch:attribute name="value">MyAuthoringSite1</patch:attribute>
         </setting>
      </settings>
   </sitecore>
</configuration>

The solution

The quick fix was to make sure the InstanceName value set on the publishing instance configuration matched to the Publishing.PublishingInstance value.  This resolved the publishing issue and no longer caused the dialog to hang on the Initializing state:

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
   <sitecore>
      <settings>
         <!-- INSTANCE NAME
            Unique name for Sitecore instance.
            Default value: (machine name and IIS site name)
         -->
         <setting name="InstanceName">
            <patch:attribute name="value">MyAuthoringSite1</patch:attribute>
         </setting>
         <!-- PUBLISHING INSTANCE
            Assigns the instance name of dedicated Sitecore installation for publishing operations.
            When empty, all publishing operations are performed on the local installation of Sitecore.
            Default vaue: (empty)
         -->
         <setting name="Publishing.PublishingInstance">
           <patch:attribute name="value">MyAuthoringSite1</patch:attribute>
         </setting>
      </settings>
   </sitecore>
</configuration>
Advertisements

2 thoughts on “Sitecore: Publishing stuck on Initializing after applying Scalability settings”

  1. Hi Jason, ran into a similar issue and while reading this post this phrase didn’t make sense – ” value set on the publishing instance matched to the publishing instance”. Please can you explain or might be a possible typo. Thanks Shriroop.

    1. Good catch Shriroop! I’ve updated the post for clarity. Essentially, the config example clarifies, but I’ve changed the text to be more specific that the Publishing.PublishingInstance and InstanceName configuration values should be the same.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s